iRET

40./42. iOS 2014.07.16 09:56


iRET


iOS에서 실행가능한 APP을 모의해킹 시 반복되는 작업을 줄이기 위한 툴



iRET을 설치하기 전에 의존성의 문제로 필요한 작업이 존재한다. 아래 툴들이 iRET을 설치 할 디바이스에 필수 로 설치되어야 한다. 해당 툴은 Cydia를 이용하여 쉽게 설치 가능하다. Cydia에서 설치 불가능하다면 apt-get을 이용하여 다운로드 및 설치 가능하다.

 - Python (2.5.1 or 2.7) (Need to be Cydia ‘Developer’)

 - coreutils

 - Erica Utilities

 - file

 - adv-cmds

 - Bourne-Again Shell

 - iOS Toolchain (coolstar version)

 - Darwin CC Tools (coolstar version)

 - An iOS SDK (presumably iOS 6.1 or 7.x) installed to /theos/sdks













iRET의 경우 소스코드가 공개되어있으며, python으로 작성되어있다.

python 소스를 분석하면 iRET을 구동 시 필요한 툴을 find를 이용하여 검색하고 해당 PATH을 변수에 저장하여 사용한다. 특정 툴이 (Not install)이 표시되는 경우는 해당 라이브러리나 프로그램이 설치가 되지 않아서 찾을 수 없기 때문이다. 해당 툴을 직접 설치하고 재시작하면된다.




1 ··· 31 32 33 34 35 36 37 38 39 ··· 123 

카운터

Total : 90,181 / Today : 10 / Yesterday : 31
get rsstistory!